BMW F650 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
This list goes on, have not managed to to 5 miles on this bike now without a break-down.

Fitted a new voltage regulator and battery a few weeks ago, maybe 25 miles ago.2 days ago Bike failed to start. Flat battery, charged the battery. Battery goes flat again. Did the multimeter test again, got readings around 12.14v with engine running, no variation when revving. 12.4v with engine off (readings after re-charged).

Has the new regulator failed? Got it on eBay, has something made it fail? What should I do?
 

·
Registered
Joined
·
317 Posts
You've got to break it down into sections; alternator, regulator, battery. Also, any old bike is going to have electrical gremlins, often due to corroded pins in connector blocks and wires that have chafed or have started to crack off.

Go to http://faq.f650.com/FMainIndex/Electrical.htm as the Clymer manual isn't a lot of use and the BMW manual is even worse.

Start from the altenator connection block and work into the system. Check ALL connector blocks in the line and check each pin for security and "green mould".

It is rare but not totally unknown that the alternator itself has gone but you can do resistance and balance checks on each of the coils. Check the connection block pins.

https://www.youtube.com/watch?v=JqE-Qw0PfF0 for altenator testing. You won't get an output if no input.

You can check the regulator if you can get access to a bench-top AC supply used for testing purposes.

Check the regulator wires in, connector blocks in, and wires out and connector blocks out for continuity. The regulator could be OK but the electrons are stopped rattling along the wires by dodgy connections. You need to check output at the connector block, not just at the battery.

Check all the earthing points for the regulator and battery that they are clean and secure.

You do need to know how to check for current as well as voltage, just because there is voltage doesn't mean there is current. That means a good electrical meter and knowing how to use it.

As I tell my apprentices, everything is guilty unless proved innocent. If you don't take that on-board, at best you'll look a fool one day and at worst you'll kill someone.
 

·
cryospeed1
Joined
·
161 Posts
I had a similar problem on my 1999 funduro a few years back. I too replaced the regulator and battery to no avail. By a process of elimination it turned out to be a live from the battery to the ignition switch. I by passed it and I had ignition. The three yellow wires from the alternator were also a bit fried. Eventually I fitted a second hand loom and had no more issues.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Since my last posting, I have checked and cleaned every earthing point and connection. Tomorrow I will do the checks with meter.

I have read that you can disconnect voltage regulator to test. Will bike run with it disconnected? Is it disconnected before starting or after?
 

·
Registered
Joined
·
317 Posts
Disconnect before starting from the altenator connection as it shows in the video. Check for continuity and resistance of the alternator coils at the alternator connecting block with the engine off. Plug the alternator back in then check again on the pins on the loom side of the connector block. You should get virtually identical readings.

Disconnect the alternator again. Start the engine. You will be using your battery charge to run the bike ignition circuit and the battery will run down with no regulator attached but should run long enough to get readings off the alternator. Best to get a second pair of hands to hold connectors while you prod them with the meter probes so you can do the job quickly. Remember you're testing for AC voltage off the alternator and DC voltage off the regulator when setting the meter. Unless you have an auto-ranging meter, set higher than expected output (200 V range off the AC and 20 Volt off the DC scales).

Check alternator output, reconnect to regulator, test the AC input into the regulator on the input and output sides of the connector block. Once the wires vanish into the regulator, you can only then check the DC output at the connector block feeding the DC into the system. As before, check BOTH sides of the connector block. As I indicated, short of finding a bench-top AC power supply unit, you can't test the regualtor function off the bike.

Best of luck.
 
1 - 7 of 7 Posts
Top