BMW F650 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
so i got the bike with the rear switch stuck open. so unplugged it and now just have front light, tried bleeding it with an airbleeder and worked intermittently. but would stick on after a awhile of using the rear brake. so ordered a china banjo switch to replace it. well fitted it and for some reason its not working at all. any help if others have this same issue.
front switch works perfect. so just the back giving me issues. my next idea is to remove the hydraulic switch altogether and replace it with an different style switch
thanks
 

·
Registered
Joined
·
1,763 Posts
so i got the bike with the rear switch stuck open. so unplugged it and now just have front light, tried bleeding it with an airbleeder and worked intermittently. but would stick on after a awhile of using the rear brake. so ordered a china banjo switch to replace it. well fitted it and for some reason its not working at all. any help if others have this same issue.
front switch works perfect. so just the back giving me issues. my next idea is to remove the hydraulic switch altogether and replace it with an different style switch
thanks
Is it just switch sticking or does brake stick on too or able to spin wheel freely after apply rear brake. Which version do you have ? Is it similar to a car switch IE hydraulicly operated , if so replace switch. Sounds like brake sticking ? Crude gets into rear master cylinder when rubber boot wears / dissentergrated.
My F650 GD 2004 is primitively micro switch, returns to off position by spring, crude go into works so stuck, replaced.
 

·
Registered
Joined
·
3 Posts
so i got the bike with the rear switch stuck open. so unplugged it and now just have front light, tried bleeding it with an airbleeder and worked intermittently. but would stick on after a awhile of using the rear brake. so ordered a china banjo switch to replace it. well fitted it and for some reason its not working at all. any help if others have this same issue.
front switch works perfect. so just the back giving me issues. my next idea is to remove the hydraulic switch altogether and replace it with an different style switch
thanks
What year and model????
 
1 - 3 of 3 Posts
Top