BMW F650 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi All,

having a problem with my fuel light.

The fuel sensor appears to be working (have tested it with a mustimeter and get a High resistance on what should be a full tank and around 1ohm for empty. The issue I am having is the low fuel light doesn't come on during low fuel but the lamp works when I turn the ignition on for the lamp test.

Any ideas?
 

·
Registered
Joined
·
312 Posts
Assuming it is an 00-09 year model, the next step is confirming the dash plug is fully seated, testing continuity between plug at the fuel tank & the dash plug, you can put an earth on the White/Green wire at the fuel tank plug to do a quick test, dont forget there is a time delay between putting an earth on the wire to the dash & the dash lamp coming on & then latching on, turning ignition off/on resets the lamp
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Assuming it is an 00-09 year model, the next step is confirming the dash plug is fully seated, testing continuity between plug at the fuel tank & the dash plug, you can put an earth on the White/Green wire at the fuel tank plug to do a quick test, dont forget there is a time delay between putting an earth on the wire to the dash & the dash lamp coming on & then latching on, turning ignition off/on resets the lamp
Hi Wayne, mine is a 2011 Model. I guess the same should be true though. Although I have had problems tracking down some schematics for it as they all seem to be for the F650GS and they may or may not be the same.
 
1 - 4 of 4 Posts
Top