BMW F650 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi, I have a 1995 Funduro which has developed a starting problem. Riding the bike the other day it just cut out on me as I got home. Wouldn't start, just cranked over. I took off the carbs and cleaned them ( although I didn't find anything blocked and they were very clean inside. Checked the inline fuel filter at the T junction and it is also clear. Noticed that there was some fuel in the bottom of the air filter. Set the mixture screws to 3.5 turns each carb.
Charged the battery, put it all back together again. Now the bike will start but within 2 seconds stop running. I can't get it to idle at all Sometimes it also will backfire when starting. Spark is very good, checked the coils and put New spark plugs in. Anyone got any other ideas??? Thanks!.
 

·
Registered
Joined
·
31 Posts
Hi Kenken Try Starting the Bike with the Fuel Cap OPEN, The Tiny Vent hole on the Fuel Cap Could be Blocked Creating a Vaccum Always worth a Try , Plus Check the Side Stand Switch is not stuck with Gunge as that would Stop the engine from Starting. Hope this Helps Cheers Francis
 

·
Registered
Joined
·
13 Posts
Hi Kenken Try Starting the Bike with the Fuel Cap OPEN, The Tiny Vent hole on the Fuel Cap Could be Blocked Creating a Vaccum Always worth a Try , Plus Check the Side Stand Switch is not stuck with Gunge as that would Stop the engine from Starting. Hope this Helps Cheers Francis
Would the side stand only stop the bike when you drop it in gear (not in neutral)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Tried again today with the fuel cap off....no difference :-(
Now it's only starting with a spray of easy start into the airbox, and still only runs for a couple of seconds before dying.
Checked and still getting sparks and fuel through.
Do you think it could be the ECU? Is there any way to check this?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
SOLVED - I had put new handlebar switches on and they came without a wiring diagram. I figured out what colour wires went where and made up a new wiring diagram for the bike. Unfortunately during connection I had mixed up two wires from the start switch and engine kill switch. Amazed that it still wanted to try to start but explains why as soon as I took my finger off the starter it died. Having swapped over these two connections the bike is now starting....and running!!
Thanks for your helpful suggestions.
 

·
Registered
Joined
·
1,763 Posts
Good you solved the issue, an unusual one, good lesson if you have starting/running problems , track back if you have made any changes . . . . . . .
 
1 - 7 of 7 Posts
Top