BMW F650 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all
I'm desperately trying to get my dads 1995 f650 funudro working.

Symptoms
Starts okay, idles alright when warm occasionally cuts out when cold.

When riding , in any gear at around 3000 revs maybe more, it backfires/stalls/loses all power and stumbles.

What I've done
I've refurbished the carbs with a refurb kit ,I've done basic service including oil and spark plugs, the air filter is okay. I've checked the rectifier using a multimeter it read 14.6 (that seems okay).

I'm running out of ideas of what could be causing these issues . Could it be valve clearances possibly plug caps ?

Any ideas

Thank you scott
 

·
Registered
Joined
·
320 Posts
Hi all
I'm desperately trying to get my dads 1995 f650 funudro working.

Symptoms
Starts okay, idles alright when warm occasionally cuts out when cold.

When riding , in any gear at around 3000 revs maybe more, it backfires/stalls/loses all power and stumbles.

What I've done
I've refurbished the carbs with a refurb kit ,I've done basic service including oil and spark plugs, the air filter is okay. I've checked the rectifier using a multimeter it read 14.6 (that seems okay).

I'm running out of ideas of what could be causing these issues . Could it be valve clearances possibly plug caps ?

Any ideas

Thank you scott
Always a risk that a previous owner has done something and then you might put things back "as they were" rather than "as they should be according to the manual"
It sounds like a fuelling problem (as with all things though, everything is guilty until proven innocent when it comes to fault-finding)
If original plug caps, they have been flagged up as possible problems although would tend to affect a wider RPM range
Valves unlikely as it would affect all RPM's and only when hot engine.
You don't say exactly what you have serviced on the carbs but at this age anything "soft" will be getting past it's best.
Float heights? Awkward to check but worth spending some time on using a sound method of checking.
Intake manifold cracks \ joint leaks and air box joints
Blocked fuel supply or breather hole into fuel tank
VR reading seems OK. Checked at correct RPM? Check the reading at the battery rather than the multi-pin as the pins \ crimps can "go green" and crumble due to moisture or even go flaky due to overheating from a dodgy VR in the past
Water lurking in the fuel at a low point in the fuel system
If the problem pre-dates the carb service, it might be needle \ main jet transition point (controlled by needle groove position) and \ or wear with those parts

Linked to age is the condition of electrical connections. While not contributing directly to ignition \ VR problems it can affect running if other bits are not quite up to scratch.
 
1 - 3 of 3 Posts
Top