BMW F650 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hope someone can help or advise please? While riding the bike feels like it is running out of fuel. If you start it and let it idle it cuts out after a minute. Will only run if you hold revs at about 3 or 4000. Fitted new plugs. New filter/regulator. New fuel pump. I have noticed engine temp light flashes three times when ignition turned on. Is this normal or some sort of blink code?
Any advice appreciated.
 

·
Registered
Joined
·
1,763 Posts
Which bike do you have? Yr & model helps narrow down possible issues,
Quick check, battery terminals not loose? Check battery voltage static and running, ideally about 12.6 v or more static depending on age of battery, shiuld max out at around 14.5v , reduce once charged up , if holding charge . Pre 2000 bikes had VR that allowed excess voltage after time, causing running issues, 2000 onwards have improved VR and remounted in air flow to keep,cool, over heating may have been factor on the previous models. See FAQs for more detailed info on this,
Pre 2000 bikes with carbs can have wear on needles, jets, , blockages from fuels over time, water in float bowls, punctured or Badley adjusted floats, rubber carb manifolds can crack/perish, let in air , weak mixture, they can distort once running, so move about when checking. Check ignition leads, corrosion ,,breakages common, replace if old! These are a few basic checks, look at FAQs for further help, looking at connections etc
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Which bike do you have? Yr & model helps narrow down possible issues,
Quick check, battery terminals not loose? Check battery voltage static and running, ideally about 12.6 v or more static depending on age of battery, shiuld max out at around 14.5v , reduce once charged up , if holding charge . Pre 2000 bikes had VR that allowed excess voltage after time, causing running issues, 2000 onwards have improved VR and remounted in air flow to keep,cool, over heating may have been factor on the previous models. See FAQs for more detailed info on this,
Pre 2000 bikes with carbs can have wear on needles, jets, , blockages from fuels over time, water in float bowls, punctured or Badley adjusted floats, rubber carb manifolds can crack/perish, let in air , weak mixture, they can distort once running, so move about when checking. Check ignition leads, corrosion ,,breakages common, replace if old! These are a few basic checks, look at FAQs for further help, looking at connections etc
Thank you for reply. It is a 2004 Dakar model. Injected. I have just got myself a volt meter. I will check the charging on Sunday when I get a bit of time. Lets hope!
 

·
Registered
Joined
·
2 Posts
I had the same problem a couple of years back - posted on here about it under a different ID ( new email address) but have a look at


The culprit was the idle valve and the total cost of fix was some squirty carb cleaner, a bit of rag and a small bolt. Plus some hours on google, fewer hours removing the stepper motor (drilled out a bolt) and 10 mins cleaning it.

Hope it works for you
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I had the same problem a couple of years back - posted on here about it under a different ID ( new email address) but have a look at


The culprit was the idle valve and the total cost of fix was some squirty carb cleaner, a bit of rag and a small bolt. Plus some hours on google, fewer hours removing the stepper motor (drilled out a bolt) and 10 mins cleaning it.

Hope it works for you
Thank you for your reply. Your symptoms sound the same as my bikes, but my one is fuel injected so still scartching my head!
 
1 - 7 of 7 Posts
Top