BMW F650 Forums banner
fuse
1-14 of 14 Results
  1. F650 Single Discussion
    Riding to work on my 2004 F650GS last week the indicators stopped working completely. When I rode home they worked again then stopped. The same for three days before they gave up completely. Fuse was good (horn/light/brake lights still working) and switched the relays around to no avail...
  2. F650 Single Discussion
    Hi, I have a 2004 Twin Spark, and the clock and tripmeter have started to reset every time I switch on the ignition, as well as the re-indexing noise of the speedo and rev counter. I've traced this to a missing permanent feed on the red/white wire to the dash. I'm wondering if anyone has any...
  3. F650 Single Discussion
    Hi, Got a problem here that very suddenly occured "over night" so to say: About a week ago, installed a new battery (AGM, with higher crank power). Everything worked just fine. Now ALL of the indicators stopped working. (Not sure if it's got to do with the new battery – but I wouldn't think...
  4. F650 Single Discussion
    Hi a bit mystified! Got back last week from a 4000 mile trip down to italy on my 1999 funduro which I have owned for a couple of months. Bike never missed a beat no probs at all. The bike has been stood about 5 days and this morning it cut out after 100 yds. Pushed it back and so far it has seen...
  5. F650 Single Discussion
    My lights in the pannel don't go when swith is on and don't crank the starter motor
  6. F650 Single Discussion
    Hi all, This is my first post so hopefully someone can help:thanks2: Stopped yesterday and my 20amp fuse blew (no ignition lights, bike would'nt start). Replaced fuse and it blew as i put it in, keys weren't in ignition. After a bit of trial and error found that if i disconnected the VR all was...
  7. F650 Single Discussion
    HELP! I have just replaced my battery with a new one from BMW on a 06 GS . on switching on ignition , the brake light / indicator / panel light fuse blew . I replaced it with a spare and that blew too :mad: . What have I done wrong ?? :oops: The bike started ok , and headlight dipped and...
  8. F650 Single Discussion
    Looking through the faq's here, there, and it seems every where :-( all the wiring diagrams don't seem to show the fuse box with 8 fuses in. And my 2006 bike has 8 and not the commonly shown 4 :doh: Like in this thread...
  9. F650 Single Discussion
    Hi All, the 15A fuse is blowing when I switch to high beam on a F650CS. The wiring at the headlight looks fine. Where should I look next? Cheers, Ray
  10. F650 Single Discussion
    Can I pick the collectives brains and try and sort out a problem with the electrics on a 2004 model 650GS please. LAsat night while riding the bike the instrument panel went dead, engine still running, headlights working but no speed, revs warning lights or indicators. Found that a 7.5 amp...
  11. F650 Single Discussion
    Has anyone fitted the Centech AP1 Fuse Panel and the associated AP-170R Relay on their 650GS? Got the kit just short on ideas how to fit :think: Was hoping for some guidance :dance: Any assistance would be greatly appreciated.
  12. F650 Single Discussion
    Morning All In the past 2 days after long runs I have blown the No1 Fuse in my fuse box. The fuse in the No 1 position was a 7.5amp but according to the book it should be a 20.00amp could anyone confirm the correct fuse needed. I almost missed my ferry back from Dublin . Thanks LPP2
  13. F650 Single Discussion
    hi everyone, wonder if you can help? recently bought a 02 cs fantastic bike, only problem seems to be the high beam keeps blowing the fuse for the lights, i took it to bmw for its annual service & told them of the fault but when they tested it they couldnt make the fuse to blow, they tried it...
  14. F650 Single Discussion
    Can anyone help me out their :? I left my funduro out in the rainstorm :not worthy: and now it keep's blowing the 15amp fuse.It seams to happen when it' starts up from cold in the morning.Can anyone help with an cure :? (apart from not leaveing it in the rain).Also is this a common fault i...
1-14 of 14 Results
Top