Very High Idle

Results 1 to 8 of 8

Thread: Very High Idle

  1. #1
    Bike
    F650GS, 2000
    Join Date
    Oct 2014
    Location
    Bath
    Posts
    50
    Post Thanks / Like

    Default Very High Idle

    Hey there good folks,

    I'm after some advice if anyone can help?

    I have had a lot of the bike apart to replace head bearings and the water pump, oh what a joy the stupid oil return pipe is! I did also replace one of the hoses from the tank to the fuel filter as well as usual service items.
    Anyway, having put it all back together, when I start it up, its revving at 4500 rpm at idle, the throttle is closed, don't touch that when starting and as the side panel is off can see that its closed. Battery was removed for several days during all that so I assume the BMS reset itself.
    Any ideas? I guess I've disturbed something in all the removing and replacing?

    Cheers

  2. #2
    Bike
    F650(1997) & F650GS(2000)
    Join Date
    Aug 2004
    Location
    Bedford.
    Posts
    841
    Post Thanks / Like

    Default

    As you have the side off disconnect the throttle cable from throttle body and start it - is the idle still high ?
    to confirm not a issue from cable side.

  3. #3
    Bike
    05 Dakar
    Join Date
    Dec 2006
    Location
    Ombersley, Worcs
    Posts
    1,189
    Post Thanks / Like

    Default

    As above really. Although the throttle may be closed, has the cable fully returned on the throttle body? Is the idle actuator ok too? May be worth removing and cleaning.

  4. Remove Advertisements
    F650.co.uk
    Advertisements
     

  5. #4
    Bike
    F650GS, 2000
    Join Date
    Oct 2014
    Location
    Bath
    Posts
    50
    Post Thanks / Like

    Default

    Ta for replies, I've been distracted by what counts as normal life since Thursday!
    I've just been out and disconnected the throttle cable, yes that the issue, thanks for that suggestion, glad its a simple new cable needed.

    Cheers
    Last edited by Huey650; 26-09-2020 at 02:55 PM.

  6. #5
    Bike
    GS/Gd Dakar 2003
    Join Date
    Oct 2008
    Location
    wakefield
    Posts
    1,730
    Post Thanks / Like

    Default

    Quote Originally Posted by Huey650 View Post
    Ta for replies, I've been distracted by what counts as normal life since Thursday!
    I've just been out and disconnected the throttle cable, yes that the issue, thanks for that suggestion, glad its a simple new cable needed.

    Cheers
    at full adjustment? Try re routing , unless cable U/S.
    2003 GS Dakar
    BMW Panniers, top box, tank bag
    + loads TT stuff that came with it!

  7. #6
    Bike
    F650(1997) & F650GS(2000)
    Join Date
    Aug 2004
    Location
    Bedford.
    Posts
    841
    Post Thanks / Like

    Default

    Did you have the cable in the right position on the pulley ?

    Can not attach pic but it has 2 possible positions use the smaller cam.

  8. #7
    Bike
    F650GS, 2000
    Join Date
    Oct 2014
    Location
    Bath
    Posts
    50
    Post Thanks / Like

    Default

    I took it off completely to assess and it was not in good condition, so I'll replace it, it is quite likely the original and bikes done 75k, so its done well.
    Cheers

  9. #8
    Join Date
    Sep 2020
    Posts
    6
    Post Thanks / Like

    Default

    Although the throttle may be closed, has the cable fully returned on the throttle body? Is the idle actuator ok too? May be worth removing and cleaning.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •