My motor is a zombie. It's comes alive when it is off. Help

Results 1 to 3 of 3

Thread: My motor is a zombie. It's comes alive when it is off. Help

  1. #1
    Join Date
    May 2020
    Posts
    3
    Post Thanks / Like

    Default My motor is a zombie. It's comes alive when it is off. Help

    Hi all. I have a F650GS (with the 800cc motor). Purchased in 2012. The issue I have is, when I turn off the engine and remove the key, there is a noise in the instrument cluster followed by the tacho, speedometer and the multifunctional display come on for 2 seconds and then disappearing again. This is repeated about 3 or 4 times per minute. The only way to stop it is the disconnect the battery. Can anyone help with a diagnosis and a cure?

  2. #2
    Bike
    2014 F800GS
    Join Date
    Jun 2006
    Location
    Moray
    Posts
    425
    Post Thanks / Like

    Cool

    Hi Aussie Gregg.

    My sons F800GS had a similar problem. The bottom of the ignition switch has a cam system that opens and closes a switch when the key is rotated.

    It can be replaced seperatly so you don't need a whole ignition unit. We replaced the offending item and made sure the repalcement was properly water tight.

    Check out UKGSer - the problem has been discussed over there several times.

    https://www.ukgser.com/forums/showth...merged-thread)

    Hope thats all it is.

    SteveT

    Last edited by SteveT; 28-05-2020 at 06:31 PM.
    ZEN DOG
    He knows not where he's going, for the ocean will decide
    It's not the destination . . . . . . . it's the glory of the ride

  3. #3
    Join Date
    May 2020
    Posts
    3
    Post Thanks / Like

    Default

    Thank You. I'm off to the BMW shop to have it repaired. At least now I know what the issue is so I can discuss the problem with some knowledge.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •